System Requirements

  • JDK: Cayenne, including GUI tools, is written in 100% Java, and runs on any Java-compatible platform. Required JDK version is 1.5 or higher. (The last version of Cayenne compatible with JDK 1.4 is 1.2.x/2.0.x; JDK 1.3 - 1.1.x)
  • JDBC Driver: You will need a JDBC driver to access the database. Information about various drivers and database-specific configuration is provided on the Database Support page.
  • Third-party Libraries: Depending on the application nature, Cayenne may optionally require a few third-party open source packages. See JAR Files and Dependencies page for details.

Obtaining Cayenne

Installing Cayenne is simple - just download and unpack the distribution. Download page is located here: Select a distribution for your development platform (cross-platform version, as the name implies, works on any OS that has Java).

Once you've done that, you can start the Modeler and use appropriate jar files in your application. See JAR Files and Dependencies for more information.

If you are using Maven2, the runtime dependencies can be obtained in a standard Maven way (i.e. by declaring them in the POM), still you likely want to download the distribution, as it includes the Modeler.


  1. Upgrade
  2. JAR Files and Dependencies
  3. Cayenne and Maven